1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ran into 2 issues aftert install

Discussion in 'Install Logstash and Kibana on a Windows server.' started by estol, Feb 24, 2016.

  1. estol

    estol New Member Member

    I never got the green create on the kibana page:
    http://imgur.com/KwTV7Fq
    Unable to fetch mapping. Do you have indices matching the pattern?

    [Disregard] Java is maxing out the cpu on my server. (Only 1 cpu core was asigned to the server)

    I ran into both of these issues twoards the end of the day yesterday and have just started trying to troubleshoot. However I have a very hard deadline on getting this server up and running so I am reaching out for any help peopel can provide. Thanks in advance
     
    Last edited: Feb 26, 2016
  2. sbagmeijer

    sbagmeijer Machine

    You probably are using a newer logstash version the the guide? Since it looks slightly different now, I did not have the time yet to test the new version and update the guide.

    Also the Java maxing cpu did you add the "run.bat" file that should resolve it.
     
  3. estol

    estol New Member Member

    Yes I'm using the latest logstash

    run.bat
    located in \logstash-2.2.2\bin
    logstash.bat agent -f logstash.conf
     
    Last edited: Feb 24, 2016
  4. sbagmeijer

    sbagmeijer Machine

    I will give it a test with the new logstash, but in the main time maybe try remove the run.bat, it could be they have done fixes in the new version that it works fine without.

    run.bat we created because before without we had the cpu problem, but maybe try make a service with directly: logstash.bat agent -f logstash.conf

    Also try start all services manual from cmd, then you can see more error logging and it could give you some indication why you not get logs to ES.

    I will see if I can see some problem when I try it with the new version now.
     
  5. estol

    estol New Member Member

    cmd: nssm edit logstash

    Path: C:\*\logstash-2.2.2\bin\logstash.bat [instead of run]
    Startup directory: C:\*\logstash-2.2.2\bin
    *edited to fit my install


    After a reboot cpu is still pegged at 99%

    stoping and then starting logstash,kibana, and nxlog servies via comand promt returns no errors.
    (all 3 stopped then all 3 started in order)

    If I only start the logstash service and not kibana/nxlog this also maxes out the cpu

    of note:
    If you wish to adjust the memory Logstash does use then simply open the file "logstash\bin\logstash.bat" and the change the following two lines accordingly to the amount of memory you wish it to use:
    set LS_MIN_MEM=256m
    set LS_MAX_MEM=1g

    these lines arent in that file
     
    Last edited: Feb 24, 2016
  6. sbagmeijer

    sbagmeijer Machine

    I have changed the whole guide to how I use it now days also to a new shipper.
    Please try change the things how they are now, for me it has no problems with cpu :/

    And yes it changed allot the updated version now says:
    If you wish to adjust Java related Logstash settings such as memory you can do this in the file "logstash\bin\setup.bat".
     
  7. estol

    estol New Member Member

    thanks ill let you know how I fare
     
  8. sbagmeijer

    sbagmeijer Machine

    [​IMG]

    This is how it looks for me it has been up for around 40 minutes, (running on a Amazon m4.xlarge if you interested in specs.)

    I have to go now :) back tomorrow morning (Sweden time).
     
  9. estol

    estol New Member Member

    I still seem to have the same Unable to fetch mapping. Do you have indices matching the pattern?
    error. (yes I did see the I changed the "logstash-*" to "filebeat-*")


    I'm goign to start from scratch tomorrow instead of tryign to hodge podge the new instructions on top of the old ones.
     
    Last edited: Feb 24, 2016
  10. estol

    estol New Member Member

    So interesting bit of info:
    I started completely fresh on a new install of Server 2012
    I thought I ran into the same issue again:
    Unable to fetch mapping. Do you have indices matching the pattern?
    Changing logstash-* to filebeat-* would not cause the button to change

    I fixed this by unchecking the fist box Index contains ...
    Then re-checking the box then changing logstash-* to filebeat-*
    For whatever stupid reason this worked I got my green box and my server is up and running.

    Thank you sbagmeijer
    Your assitance here and your guide were immensely helpful and appreciated
     
  11. sbagmeijer

    sbagmeijer Machine

    Great to hear it works now, strange that you had to uncheck the box and re-check it.
    Maybe it just had not enough data yet to make a index and that is why it took a little for it to get green, I had once before I had to reload the page multiple times and then it worked.
     

Share This Page