1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Nginx shows blank page.

Discussion in 'Install XenForo using Nginx and HHVM on Fedora.' started by phenomenal, Feb 18, 2016.

  1. phenomenal

    phenomenal New Member Member

    hi sir :)
    how are u
    sir i am using nginx reverse proxy ssl for apache.. nginx and apache both are working fine but the issue is when i try to install xenforo or any wordpress its not taking to me to installation process its showing me this blank page :(
    i installed this in local server
    thank u sir
    [​IMG]
     
    Last edited: Feb 19, 2016
  2. sbagmeijer

    sbagmeijer Machine

    Hi could you perhaps show me your nginx.conf and your vhost?
     
    phenomenal likes this.
  3. phenomenal

    phenomenal New Member Member

    now working fine sir i made it with the help of ur tutorial thank u

    this are my nginx.conf and vhost file sir.

    Code:
    # For more information on configuration, see:
    #   * Official English Documentation: http://nginx.org/en/docs/
    #   * Official Russian Documentation: http://nginx.org/ru/docs/
    
    user nginx;
    worker_processes auto;
    error_log /var/log/nginx/error.log;
    pid /run/nginx.pid;
    
    events {
        worker_connections 1024;
    }
    
    http {
    #   include       /etc/nginx/mime.types;
    #   default_type  application/octet-stream;
    
        log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
                          '$status $body_bytes_sent "$http_referer" '
                          '"$http_user_agent" "$http_x_forwarded_for"';
    
    
        access_log  /var/log/nginx/access.log  main;
    
        charset   utf-8;
        server_tokens       off;
        sendfile            on;
        tcp_nopush          on;
        tcp_nodelay         on;
        keepalive_timeout   65;
        types_hash_max_size 2048;
        add_header X-Content-Type-Options nosniff;
        add_header X-XSS-Protection "1; mode=block";
        limit_req_zone $binary_remote_addr zone=blitz:10m rate=5r/s;
        limit_req_zone $binary_remote_addr zone=slimitss:10m rate=1r/s;
        limit_req_zone $http_x_forwarded_for zone=one:10m rate=1r/s;
        limit_req_zone $binary_remote_addr zone=req_limit_per_ip:10m rate=5r/s;
        limit_conn_zone $binary_remote_addr zone=conn_limit_per_ip:10m;
        limit_req zone=slimitss  burst=10;
         limit_conn conn_limit_per_ip 10;
        limit_req zone=req_limit_per_ip burst=10 nodelay;
        client_header_timeout 3m;
        client_body_timeout   3m;
        client_header_buffer_size 3m;
        client_body_buffer_size  128k;
        gzip  on;
        gzip_min_length 10240;
        gzip_proxied expired no-cache no-store private auth;
        gzip_types text/plain text/css text/xml text/javascript application/x-javascript application/xml;
        gzip_disable "MSIE [1-6]\.(?!.*SV1)";
    
        include             /etc/nginx/mime.types;
        default_type        application/octet-stream;
    
        # Load modular configuration files from the /etc/nginx/conf.d directory.
        # See http://nginx.org/en/docs/ngx_core_module.html#include
        # for more information.
        include /etc/nginx/conf.d/*.conf;
        include /etc/nginx/sites-enabled/*;
    }
    
    Code:
    server {
        listen 1.2.3.4:80;
        server_name xen.in;
        access_log /var/log/virtualmin/xen.in_nginx_access_log;
        error_log  /var/log/virtualmin/xen.in_nginx_error_log;
        location / {
            limit_req zone=one;
            index index.html index.htm index.php;
            proxy_pass https://1.2.3.4:443;
            include /etc/nginx/proxy.conf;
        }
            location ~ \.php$ {
            include /etc/nginx/fastcgi_params;
            fastcgi_pass  1.2.3.4:9000;
            fastcgi_index index.php;
            fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
        }
    
    
    }
    
     
    Last edited: Feb 19, 2016
  4. phenomenal

    phenomenal New Member Member

    thank u sir i fixed it now everything fine :)
     
    sbagmeijer likes this.
  5. phenomenal

    phenomenal New Member Member

    this empty blank page is due to misconfiguration in vhost. the domain is pointing to default apache root dirctory but not to my actual domain :)
     
    sbagmeijer likes this.
  6. sbagmeijer

    sbagmeijer Machine

    Great news that everything works! Good luck with your website :)
     
    phenomenal likes this.
  7. phenomenal

    phenomenal New Member Member

    thank u sir.. please also check my config files.. if i have made some mistakes i'll try to fix them :)
     

Share This Page